Si al instalar un paquete con pip/pip3 te da error y un mensaje similar a este:

nuse@ALTARURU:~$ pip3 install PyOpenGL-Demo
...
ERROR: Could not install packages due to an EnvironmentError: [Errno 13] Permiso denegado: '/usr/local/lib/python3.6/dist-packages/PyOpenGL-Demo'
Consider using the `--user` option or check the permissions.

La solución es incluir en la instrucción el parámetro –user:

pip3 install –user PyOpenGL-Demo

nuse@NUSEBLACKMOD:~$ pip3 install --user PyOpenGL-Demo
Collecting PyOpenGL-Demo
Requirement already satisfied: PyOpenGL in ./.local/lib/python3.6/site-packages (from PyOpenGL-Demo) (3.1.0)
Installing collected packages: PyOpenGL-Demo
Successfully installed PyOpenGL-Demo-3.0.0

Saludos!

Deja tu comentario