Si ejecutas apt-get upgrade y en la salida ves el mensaje «Los siguientes paquetes se han retenido..» ha llegado el momento de hacer upgrade de tu distro.

Puedes listar los paquetes no retenidos y no actualizados con:

apt list ---upgradable

Para hacer el upgrade de versión ejecuta:

sudo apt-get dist-upgrade

Comenzarán a descargarse e instalarse los nuevos paquetes y en minutos tendras todo actualizado.

A continuación puedes eliminar los paquetes no necesarios con autoremove

sudo apt-get autoremove

Reinicia el sistema y … actualizado y listo para dar caña!

Un saludo.

4 comentarios sobre «sudo apt-get upgrade… «Los siguientes paquetes se han retenido…»»

  1. Gelacio

    ¡Porque no siempre estan actualizadas las «distros»?

    1. Cada versión de cada una de las distribuciones acostumbran tener un «periodo de garantía», por llamarlo de alguna manera, en el que la gente que lo publicó asegura que mantendrá los paquetes que lo componen funcionando correctamente. Algunas versiones tienen tiempo de soporte extendido, que pueden identificarse con las siglas LTS (Long Term Support en inglés). Se da a los usuarios y administradores de sistemas la opción de elegir entre las últimas versiones o las versiones que funcionarán por mucho tiempo, sin tener la preocupación de que algo deje de funcionar en la siguiente versión.

  2. Deyby

    Muchas gracias no tenia idea de que hacer

Deja tu comentario